CRAN Package Check Results for Package psyverse

Last updated on 2024-06-13 00:55:27 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.6 3.69 42.21 45.90 OK
r-devel-linux-x86_64-debian-gcc 0.2.6 3.20 29.05 32.25 ERROR
r-devel-linux-x86_64-fedora-clang 0.2.6 58.43 OK
r-devel-linux-x86_64-fedora-gcc 0.2.6 66.79 OK
r-devel-windows-x86_64 0.2.6 3.00 58.00 61.00 OK
r-patched-linux-x86_64 0.2.6 4.57 41.16 45.73 OK
r-release-linux-x86_64 0.2.6 3.65 40.28 43.93 OK
r-release-macos-arm64 0.2.6 31.00 OK
r-release-macos-x86_64 0.2.6 43.00 OK
r-release-windows-x86_64 0.2.6 4.00 58.00 62.00 OK
r-oldrel-macos-arm64 0.2.6 35.00 OK
r-oldrel-macos-x86_64 0.2.6 42.00 OK
r-oldrel-windows-x86_64 0.2.6 5.00 64.00 69.00 OK

Check Details

Version: 0.2.6
Check: package dependencies
Result: NOTE Packages suggested but not available for checking: 'DiagrammeR', 'haven', 'googlesheets4', 'readxl', 'testthat' Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.2.6
Check: examples
Result: ERROR Running examples in ‘psyverse-Ex.R’ failed The error most likely occurred in: > base::assign(".ptime", proc.time(), pos = "CheckExEnv") > ### Name: apply_graph_theme > ### Title: Apply multiple DiagrammeR global graph attributes > ### Aliases: apply_graph_theme > > ### ** Examples > > exampleSpec <- + system.file("inst", + "extdata", + "example_dct_spec_1.dct", + package="psyverse"); > parsedSpecs <- load_dct_specs(exampleSpec); > dctGraph <- parsedSpecs$output$basic_graph; > dctGraph <- apply_graph_theme(dctGraph, + c("color", "#0000AA", "node"), + c("fillcolor", "#00FFFF", "node")); Error: This function applies graph themes to a `DiagrammeR` object. Therefore, obviously, that object must first exist, and you need the `DiagrammeR` package to create it and work with it. Please install it using: install.packages('DiagrammeR'); Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.2.6
Check: tests
Result: ERROR Running ‘testthat.R’ [0s/1s] Running the tests in ‘tests/testthat.R’ failed. Complete output: > require(testthat); Loading required package: testthat Warning message: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, : there is no package called 'testthat' > testthat::test_check("psyverse"); Error in loadNamespace(x) : there is no package called 'testthat' Calls: loadNamespace -> withRestarts -> withOneRestart -> doWithOneRestart Execution halted Flavor: r-devel-linux-x86_64-debian-gcc